• Avatar do Utilizador
  • Avatar do Utilizador
  • Avatar do Utilizador
  • Avatar do Utilizador
Avatar do Utilizador
Por Ru13en
Posts Signature Avatar
#196772
Agradeço a tua ideia, e não é má de todo, visto que para quem quer uma vez esporadicamente é a forma mais facil...
Mas para quem quer encodar a sério, tem que aprender a usar as ferramentas certas e mais poderosas para vir a ter trabalhos bons...
Ninguem nasce ensinado e em algum sitio tem que se começar...
Daí que disse o que disse, porque se quer vir a encodar mais coisas e a editar videos, nada como começar a aprender algo do 0, mas com as ferramentas certas :godfather:
Por Charles
Posts
#207818
Estava fazendo uns testes e aconteceu algo estranho. Não consigo mais usar alguns filtros que costumava utilizar. Os plugins que tenho são os mesmos de quando não acontecia o problema. Como soluciono isso?
Spoiler
Show
Imagem
Avatar do Utilizador
Por Dahitman
Posts Signature Avatar
#207831
Já não posso ver mais erros de encode à minha frente :superangry:
Por Pandora
#224642
e eu n consigo meter o áudio...
o vídeo fica sempre sem áudio depois de passar pelo megui com avisynth

tenho um vídeo mp4 com áudio ac3 e quando vou processar o vídeo depois de o ter cortado, pq eu quero apenas cortar partes desse vídeo q n me interessam, no fim fica sem áudio, n sei como juntar o áudio.

estou a dar os primeiros passos no avisynth e aquilo para mim ainda é mto confuso.
Avatar do Utilizador
Por Leinad4Mind
Posts Signature Avatar
#224643
O que tens no script .avs?

Provavelmente estás a tratar apenas o vídeo. E o corte tb tem de ser efectuado no audio de igual forma.

Cumps
Por Pandora
#224644
no script.avs para o vídeo tenho isto:

# Set DAR in encoder to 160 : 117. The following line is for automatic signalling
global MeGUI_darx = 160
global MeGUI_dary = 117
LoadPlugin("C:\Users\AC\Desktop\Nova pasta\tools\ffms\ffms2.dll")
FFVideoSource("C:\Users\AC\Desktop\o despertar das tartarugas - parte 1.mp4", fpsnum=25, fpsden=1, threads=1)
#deinterlace
#crop
LanczosResize(704,576) # Lanczos (Sharp)
#denoise
trim(239, 32784)


e no script do áudio tenho isto:

LoadPlugin("C:\Users\AC\Desktop\Nova pasta\tools\ffms\ffms2.dll")
FFAudioSource("C:\Users\AC\Desktop\o despertar das tartarugas - parte 1.mp4", track=1)
# detected channels: 2 channels
# detected channel positions: 2/0/0
trim(239, 32784)


como acabei de dizer, trim é a coisa mais fácil de fazer, o resto ainda estou a tentar aprender, procurei tutoriais sobre como juntar o áudio e o vídeo mas n consegui fazer nada.

queria tmb aprender como usar os filtros para corrigir a imagem, pq a imagem parece ter pixéis a cintilar quando aparece uma cor mais clara, isso nota-se no logo da nickelodeon e nota-se sobretudo nos olhos claros de alguns personagens, parece q quanto mais clara for a cor mais se nota.
Avatar do Utilizador
Por Dahitman
Posts Signature Avatar
#224665
Podes juntar o vídeo e o áudio num só ficheiro.

V=FFVideoSource("C:\(...)\ficheiro.mp4")
A=FFAudioSource("C:\(...)\ficheiro.mp4")
AudioDub(V,A)
trim(0,x)+trim(y,z)

Quanto aos filtros... Só mesmo com a prática... Também comecei a aprender a aplicar filtros e a fazer melhores encodes há pouco tempo (até foi o Leinad que me ensinou os básicos), e só vais lá com prática e dedicação :D

Podes sempre dar uma olhadela a estes sites:
https://sites.google.com/site/ourenthus ... o/avisynth
http://www.afterdawn.com/guides/archive ... page_7.cfm
http://avisynth.nl/index.php/External_filters
http://www.avisynth.nl/users/warpenterprises/
Por Pandora
#224680
olha, para fazer trim ao áudio é com os frames do vídeo ou tenho de inserir outra coisa?

e o megui tem ataques de estupidez... começo a ficar irritada com ele.
Avatar do Utilizador
Por Dahitman
Posts Signature Avatar
#224685
É com os frames do vídeo, tal como meti em cima :^^:
Eu não uso o Megui para encodar o vídeo, uso o Simple x264, mas para o áudio já uso o Megui.
O Megui dava-me muitos erros, por isso o R94 aconselhou-me usar antes o Simple x264.
Por Pandora
#224690
o megui era mto mais fácil de usar q o simple x264, n entendo aquele programa...
quando metes um vídeo supostamente devia ser criado um script avs antes de tudo mas ele mete logo a encodar o vídeo... além disso n existem forma de ver o vídeo à medida q a gente vai mexendo num supostamente existente script...

q programas recomendas usar junto com o simple x264
Avatar do Utilizador
Por Ru13en
Posts Signature Avatar
#224712
Avspmod, para editarem um ficheiro avs, e ver o resultado à medida que vao aplicando filtros...
A funcionalidade do Simple x264 é semelhante ao megui... a diferença está no facto de o simple x264 mostrar as settings do x264 logo à primeira, onde o megui tem guardado nos perfis que têm que ser configurados tbm...
A mim entre usar esses 2 programas e usar antes o exe do x264, é so o facto de dar para fazer Queue e meter tudo a correr sem ter que ter o trabalho de fazer um bat que carregue os ficheiros todos LOL...
Por Pandora
#224829
já estou a criar o script com o avspmod, obrigada pela dica rui3en

eu precisava de um plugin para aliasing, os links q estão na primeira pag deste tópico n abrem e n consigo encontrar em parte nenhuma, a serie q eu ando a tratar está em cgi e está ligeiramente serrilhado, deve ter sido por causa da gravação.

lembram-se de eu ter pedido aqui a serie das tartarugas ninja da nickelodeon? e q depois um amigo meu me mandou a serie gravada da tv em pt-pt como eu queria?
ele foi um querido mas mandou-me tal como gravou, só converteu para mp4 com o handbrake e ficou com a imagem um bocadinho alterada, nota-se sobretudo na tv da sala, as tais cores que quando são mais claras e são mais brilhantes delas próprias parece q ficam a cintilar quando no original n deviam cintilar daquela maneira, a imagem um pouco desfocada onde a nitidez das linhas desaparece um bocado e ligeiramente serrilhadas.

ando a testar os filtros para ver como tiro aquela "purpurina", LOOOOL!, mas até agora n consegui encontrar o filtro certo
e preciso de alisar o serrilhado mas os links para o aliasing n existem mais, se alguém tiver plugins para isto agradecia :^^:

já estou a conseguir entrar mais ou menos no esquema disto e em apenas 2 semanas! :show:
Avatar do Utilizador
Por Ru13en
Posts Signature Avatar
#224832
Antialiasing tens scripts e plugins no forum doom9 e no site do avysinth.
http://avisynth.nl/index.php/AntiAliasing

Ha mais plugins de antialiasing por lá...
Also, para mudares as cores, nada como usar o tweak ou entao um filtro de color correction...
De resto, diverte-te nisso...
Pessoalmente, nao tenho tido tempo para voltar a encodar, mas posso sempre ajudar a esclarecer dúvidas ^^
Avatar do Utilizador
Por terechan
Posts Avatar
#224833
Em último caso, tentas encontrar uns rips melhores na net e sincronizas o áudio. xD
Por Pandora
#224834
gosto de aprender e quando entras no esquema começas a achar interessante, eu tinha alguma curiosidade sobre programação e aqui está uma oportunidade de aprender e ficar a conhecer um pouco daquilo que eu sempre achei q era um bicho terrivel! XD
confesso q no incio cheguei a pensar q devia estar louca para me meter nisto... tinha de ler 50 vezes para perceber e mais 50 antes de fazer alguma coisa mas agora nem tanto, está a ficar mais fácil.

conheço um site, o animebb.tv, q tem a serie toda em hd mas n sei como sacar de lá os episódios, n consegui encontrar até agora nenhum programa q fizesse isso, os programas normalmente só sacam do youtube e pouco mais, se conseguisse era isso q fazia...
é q o animebb.tv tem os vídeos online, aquilo é só para chegar lá e assistir.

posso usar o script sem ter o plugin? n me parece...
Avatar do Utilizador
Por Ru13en
Posts Signature Avatar
#224839
Se queres aprender programação, aprende Python e usa o vapoursyth... Está a ficar cada vez melhor que o avisynth, e será o futuro da edição de videos em termos de programação...
Obvio que precisas de ter o plugin... sem isso os scripts nao funcionam lol...
Por Pandora
#224843
a terechan disse q para eu n ter tanto trabalho procurava rips melhores na net e metia o áudio PT-PT, conheço um site q tem só 4 episódios em PT-PT, os episódios tem uma qualidade de imagem mto pior q estes em q estou a trabalhar, mas mto pior! LOOOOOL!
aqueles é q posso dizer q têm problemas na imagem bem sérios!

rui3en, o avspmod e o avisynth n são maus para quem está a começar, tenho de ir com calma para já, com tempo e perseverança chega-se lá ;)
Por Pandora
#225113
já fiz o meu primeiro encode mas correu mto mal...

a imagem treme, será q foi pq usei bob no tdeint para remover as linhas pretas horizontais?
terei exagerado? se calhar bastava o slow=1...

e o trim está a comer o meu cérebro... pelo menos no player do avspmod pq quando usava o megui os cortes corriam sempre bem.
é q quando corto o vídeo nas partes q n interessam, os últimos frames do filme ficam cortados, já estendi o trim para cortar mais tarde e acaba por cortar exactamente no mesmo ponto do filme, fico sempre sem os últimos segundos do filme...

será erro do avspmod ou eu preciso de fazer mais alguma coisa para além de inserir os valores do trim?
Por Son Goku
#225115
Grandes dicas sim senhora!
Gostei muito :godfather:
Avatar do Utilizador
Por Leinad4Mind
Posts Signature Avatar
#225117
"está em cgi e está ligeiramente serrilhado, deve ter sido por causa da gravação."
Procura por naa3mod. Se bem me lembro, é o melhor para cgi. Esse e o daa() ou o daa()+maa() (embora estes comem algum detalhe...)
Caso queiras experimentar todos os antialiasing que existe, experimenta a função que eu escrevi há uns anos: LSharpAAF. É um apanhado de todos os antialisings.
Se quiseres usar a minha função tudo bem. Mas recomendo apenas usar independentemente a função que pretendes. Ao instalares a minha função ficas é com todos os aliasings disponíveis para uso.
"LanczosResize(704,576) # Lanczos (Sharp)"
Não, não e não! Usa antes o Lanczos4Resize ou o Spline16Resize. Se a tua imagem precisar de sharp, usa o Spline36Resize que se bem me lembro aplica mais sharp que os outros compatriotas.
"a imagem treme, será q foi pq usei bob no tdeint para remover as linhas pretas horizontais?
terei exagerado? se calhar bastava o slow=1... "
Mostra o código disso...
"e o trim está a comer o meu cérebro... pelo menos no player do avspmod pq quando usava o megui os cortes corriam sempre bem.
é q quando corto o vídeo nas partes q n interessam, os últimos frames do filme ficam cortados, já estendi o trim para cortar mais tarde e acaba por cortar exactamente no mesmo ponto do filme, fico sempre sem os últimos segundos do filme...

será erro do avspmod ou eu preciso de fazer mais alguma coisa para além de inserir os valores do trim?"
Partilha o código... lol é que se estiveres a fazer 2 trims seguidos, tens de ter em atenção que pode estar a cortar após o corte do anterior trim e não com base nas frames originais. Por outras palavras, Trim(x,y).Trim(x,y) Não é igual a Trim(x,y)+Trim(x,y)

Cumps

https://soundcloud.com/user-171432682/a-partir-de[…]

podiam repor os links

[Convívio] Apresenta-te Aqui!

AYOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO :stuck_[…]

[Info] Jogos e Concursos

Nos que eu participava, não fazes tu